Vectorworks Spotlight

Vectorworks Spotlight is a set of tools and commands that makes drafting a light plot much simpler. And while there are third-party add-on tools and commands available to do light plots without having Spotlight, Spotlight has the advantage of being built into Vectorworks by the manufacturers. With Spotlight, the tools needed are right at hand.

Start the Plot

In Ye Olde Days, the Production Manager would send blueine copies of the floorplan and section of the theatre from which I'd work. I'd also get a copy of the plans from the scenic designer. The first thing I would do was clear my drafting board, tape down a plan view, then a piece of vellum, and start drawing. My workflow using Vectorworks Spotlight starts the same way.

These days, the theatre architecture and scenic designs usually arrive via email as a file attachment. If I'm lucky, they will show up as a Vectorworks file. If I'm really lucky, whoever drew those initial files took the same care as I do in terms of presenting the graphic information in a logical way. In this case, opening the file, importing my classes via a symbol, selecting the 2D elements, changing them to my classes, and tweaking for style is all that is necessary before copy and pasting them into my drawing. Even tough well drawn, if I copy and paste those 2D elements into my drawing without changing the classes, all of the classes used by those elements will transfer into my file with the elements. By changing them first, my file retains only my class structure.

Another choice is to create a reference to the file rather than copying its elements. Referencing is the ability to add information from one "outside" file to the working file. While I usually want the theatre architecture resident in my file, referencing is especially useful in viewing scenic design information. A benefit of referencing is that if the scenic design file is updated, those changes show up in my file automatically. Another benefit is that none of the originating files' classes import into my document.

I'm using the Vectorworks Designer series, so the suggested method to reference a file is by creating a Design Layer Viewport. Using the View>Create Viewport menu command brings up a dialog where I'll name the Viewport. As with creating Sheet Layers, Viewports have a new naming convention to work with the the Automatic Drawing Coordination.
Viewports now have a Name and a Drawing Title. The Name is used to identify the Viewport while the Drawing Title is what will be displayed if using the Drawing Label tool to note the viewport. I might fill in "Act I Scenery" in this case. Since I want a Design Layer Viewport, I'll create a new Design Layer, "ActIScenery_2d." The select source then allows me to choose an External Document and create the reference.

A note about "Absolute path" vs. "Path relative to current document." This is a rather important choice. I organize my work very carefully on my computer. I have a folder, or a directory, for every project I am working on, and all of the information related to that production goes into that one folder. I may have different directories within that folder, so there may be a scenic design folder, a research folder, a rehearsal report folder, and
so on. If that production is one of several for the same producer, it will be inside another folder for the producer. That, in turn, is inside another folder called "shows."

The majority of my work is done on a laptop. That "shows" folder, however, is synchronized to my desktop machine on a regular basis via the Internet. Often when in the office, I'll work on projects on the desktop. Those changes are synchronized back to the laptop.

I set my reference location as "Path relative to current document" so that Vectorworks will look within the same folder as the file (relative) rather than on a particular computer in a particular directory that is inside another directory (Absolute). Regardless of which current file I am working on—whether on the laptop or on the desktop—the reference, as a relative path, is current.

Once referenced, the Viewport is dealt with like any other Viewport. Visibility of layers and classes are definable. In this case, I only want the "D1 - Plan" layer, so the rest are set to invisible. Like any other Viewport, the scale within the Viewport, the view, the Rendering Mode, and so forth are also definable.

Once placed on the Design Layer, the Design Layer Viewport is treated like a single object. It can be moved as needed. Because it is vector data, in Vectorworks 2009 and 2010 the SmartCursor snaps to points in the DLVP as defined by its preferences. In order to align the Center Line and the Plaster Line, I can zoom in or use the new Snap Loupe Tool and click-drag at the intersection to start a move operation. Tabbing in to the HUD, I can set the X and Y coordinates at "0" and hit Enter to align the Viewport properly.

If the scenic design has multiple sets, I can add other Design Layer Viewports referencing that exterior file on other layers.

I've worked with a scenic designer whose design work is all done in 3D modeling. He simply switches to a top view to provide a floorplan. Therefore colors in his floorplans indicate paint colors. There is no attention paid to lineweight or what I consider "proper" drafting style. Likewise, Illustration #31, a theatre floorplan, initially came from a DWG
file, for it appears that the original file used color to define lineweight. Luckily, as with any Viewport, I am able to change the display characteristics of those referenced files by using the class override function. The Center Line, as displayed, is a lime green dashed line that is 0.18 mm thick. My standard lightweight line is a black 0.05 mm line. From the Object Information Palette, I chose to edit the class properties, and then edit the Center Line class within that Viewport. I can choose my desired attributes, and anything in that class now displays with those attributes. This does not change the original file in any way, nor does it change any other Viewport. It simply allows me to control the graphic attributes of particular classes in a particular Viewport to more closely match my desired looks.

There are times when I decide that it is easier to redraw the 2D representation of the plan view. While live sections can be used to create Viewports, and class overrides can control some aspects of the graphic attributes, drafting—and especially drafting a light plot—is still primarily about 2D output, even though it is lighting in 3D space. I'm sometimes happier spending the time to make that 2D output look the exact way I want it to look. So I'll save a copy of the file, leaving the original intact. Into the new file, I'll import my cassettes via importing my symbol library. On a new layer, I'll use my preferred line weight and drafting style to draw a new floorplan right over the existing view. I will make sure that 0,0 is in the right place, and once finished, I will select all of the drawing on that new layer and copy it. Assuming I've already created a file for the theatre architecture, I'll add a new layer named something like “Scenery2d.” Using Edit-Paste in Place, the 2D floorplan, now properly drafted and using only my classes, is placed in the new file. I'll then add some additional tweaks to the floorplan. For example, I like the proscenium to have a certain prominence, so I may add a little extra hatching or stipple to that area. This tends to lead the eye to what is traditionally the most important area of the stage—Center Stage. Likewise, walls and architecture far away from the proscenium have less importance, so their hatching may be fessened.

In these cases, I am using compositional elements to draw the viewers’ eye to where I want it to go. Yes, I view a drafting plate as a composition and all of the elements and principals of composition are at work.

I'd then do the same thing with the CL section of the theatre: assess the existing one and, if unacceptable to my practice, redraw it using my classes, proper line weight and drafting style as needed and then copy/paste it into another layer called “TheatreSection.” If the original drawings are done in 3D, I can use the Section Tool to create a referenced DLVP, again with
class overrides controlling some aspects of the graphic attributes.

After saving this new file, I'm ready to move to the next step.

I work with a designer who still drafts by hand. When I get his draftings, I either scan them piece by piece and use a graphics program to stitch them all together into a JPEG, or I use a digital camera to take a single picture of the drawing. In Vectorworks, I'll create a new layer called "scenic plan" or something similar. Using the File>Import>Import Image File menu command, the JPEG can be imported onto that active layer.

Scale becomes important here only to preserve the relationship of the scenery to the space. So, if the Layer Scale is set at ½" to match the rest of the file, and the hand drawing is done in some other scale, the JPEG will need to be scaled up or down accordingly. Luckily, the Scale Object menu command (Modify>Scale Objects...) has a Scale By Distance function where a line can be drawn over a known distance, like the size of a backdrop, and by specifying the
actual size of that line, the JPEG will scale accordingly. This command actually works with any kind of object but is very handy here.

One unfortunate aspect of using image files is that they will not "gray" like native Vectorworks objects if the layer is set to gray. Often I will want the scenery layer set to a shade of gray so that it does not conflict with the lighting work on other layers. Graying the layer using the visibility controls makes the image disappear and a red outline shows instead. Luckily since Vectorworks 2009, the opacity of a layer can be controlled via the Edit Design Layers dialog, and turning down the opacity does create the grayed look and is infinitely controllable.

Using the Vectorworks Designer Series, an image file can be set as a referenced file instead of being imported. This is a useful option if the image file is likely to change in the course of the project. For instance, sometimes changing the gray scale of an image in an image-editing program is a good option if the percentage of gray scale needed is not immediately apparent. Choose the referencing option when importing the image and then go back and adjust the gray scale in a graphics program as needed. As long as the path to the file remains the same, the image will be updated whenever Vectorworks opens that file.

Many times, a designer will provide PDF versions of the plans rather than a Vectorworks file. PDF's, like images, are importable and scalable. They can also be referenced rather than imported. One very nice thing about PDF's since Vectorworks 2009 is that if they contain vector information, they become snappable just like any other Vectorworks objects.

Sometimes the Production Manager sends a DXF or DWG file. These are also importable into Vectorworks. I start by creating a brand-new blank Vectorworks document from my Default sta. Choose the File>Import>Import Single DXF/DWG File menu command. Navigate to the file to be imported in the resulting dialog box. In the next dialog box, I generally accept all of the default options but find sometimes I will need to delete the resulting file and try again. The most obvious example of this is when accepting the defaults results in huge text sizes or huge arrowheads. I'll delete that file and import again, this time setting the Model Space's "This Scale:" to ½"=1'-0" or similar. If finishing the import results in text at a normal size (i.e. 10 or 12 pt.), I'll know I'm on the right track.

In the Graphic Attributes tab, I'll sometimes pick "Set Colors to Black and White" if there are a multitude of colors in an incoming file, unless the sender included a line weight to color map. As I'm going to change all of the objects in the file to match my classes and attributes, their initial color is not overly important.

After the import, I'll decide how much work I want to do to update the file to my standards. Since the final drawing has my name on it—not the name of whomever did the DXF—I usually choose to go full out. Depending on how much organization that draftsman did, however, that job can either be easy or a lot of work.

If a line weight to color mapping was included, this can be a good place to start. By using a custom selection (Tools>Custom Selection...), just objects with a particular color can
be selected and then changed to the desired line weight class. If unsure of which yellow represents the lightweight line, the Tools>Utilities>Create Color Chart... command will place a chart on the drawing that names all of the colors, so selections can be made with confidence.

The default import settings also map DXF/DWG layers to Vectorworks classes, so sometimes selecting all objects in a particular class yields good results, and my drafting class can be applied to that selected group as a whole.

Sometimes the only thing to do is to select each object individually and change its class to draw in the desired line weight. It is certainly tedious and slow. To keep track of what’s been changed and not changed, I’ll create a new layer, set it to display grayed, and as objects are changed, I’ll move them to that layer. That way, objects not changed will stand out from the grayed objects already tweaked.

Some objects I may choose not to show at all, so they can be moved to a NonPlot class or deleted all together. Eventually, all of the objects have been moved to the grayed layer. Make that layer active, select all the objects on it and group them. I then align the Center Line and Plaster Line—or whatever lines define the reference lines—to 0,0. Copy that group, open a new blank Vectorworks file, and use the Paste in Place command to place the group into the new file. I’ll then ungroup it.

Looking at the classes in this new document, only those used in the group should be evident. As these should match my defaults, I can instantly see if I missed some object or another in the changes. Fix that, use the Edit>Paste in Place again in a new file, and that file is ready to be used in the plot. Well, almost. Generally, as mentioned above, I’ll add some additional tweaks to the floorplan. Regardless of, or perhaps because of, the computer nature of CAD, personal touches such as additional hatching around the proscenium not only serve the composition, they make the drafting look more “hand-drawn.”

If a 2D Center Line Section is provided, the whole process is repeated with the section. Generally the section will end up with the same classes controlling graphic attributes as the floorplan, so I’ll usually end with both drawings on separate layers of the same file, saved into the show folder.

If the provided files are primarily 3-dimensional information, I’ll use that to draw a whole new 2D floorplan and section. While live sections can be used to create Viewports and class overrides can control some aspects of the graphic attributes, drafting—especially drafting a light plot—is still primarily about 2D output, even though it is lighting in 3D space. I’m happier spending the time to make that 2D output look exactly the way I want it to look.

Once done, I have a Vectorworks file that can be either pasted into or referenced into what will be my plot file. That file might be referencing two or three different files to get the theatre architecture in plan view on one layer, the scenic plan view(s) on another layer(s), the theatre section on a separate layer, and the scenic section on yet another layer. Changing
the stacking order of the various layers becomes important so that the scenery plan view is above the theatre architecture, and the scenic section is likewise over the theatre section.

At this point I'll usually create two more saved views. I'll turn on or off classes to get the visibilities I want. Using the Center Page command and the Normal Size command to set the same view as the 0,0 saved view, I'll then make the plan layers active and save that view. Next, I'll make the section layers active and save that view as well.

With the theatre architecture and the scenery available in the plot file, the next steps will begin to use some of the tools available in Vectorworks Spotlight.
Positions

Before lights can be hung to light the stage, there has to be somewhere to hang them. These lighting positions are either architecturally defined or added on a show-by-show basis. In either case, the process of creating them in Vectorworks remains the same.

In an existing Theatre Drawing, I'll first move to my top/plan view using a saved view. Then I'll create a new layer named "positions," ensuring that it has the same scale and other options to match the existing layers. I'll make that the active layer.

I might start with the first Front-of-House (FOH) position. I'll draw a rectangle to represent the hanging pipe of that FOH position. I'll start to draw the rectangle, then tab into the HUD to enter the size. The rectangle in Illustration #36 is 44'-9" long and I usually use 2" wide. And yes, I do know that a piece of typical pipe used in such a situation really has an OD that is marginally less than that. Using 2" wide is "...close enough for rock 'n' roll," as we used to say on the road, and is a whole lot faster to type.

Once drawn, I'll assign my Draft-Medium class to the rectangle and make sure it is in the proper place on the floorplan by entering the X and Y coordinates via the OIP. I can also select it and drag it into the proper place, but the OIP is much faster.

Even though the final output will be a 2D drawing, Vectorworks Spotlight works in both 2D and 3D. Indeed it is 3D space that gives many of the Vectorworks Spotlight tools their power. So, all lighting positions need to have a 3D component as well as a 2D component. The rectangle just drawn will be the 2D representation on the plot. I also need to make the 3D version for use in 3D space.

So, with the rectangle selected, use the duplicate command. Having set my duplicate preferences to not offset, this creates a rectangle in exactly the same place as the original. With the duplicate still selected, extrude (Model>Extrude) the rectangle 2". This creates a 3D cube that is 2"x2"x44'-9".

But wait! Isn't the pipe that lights are hung on actually circular in nature? Why, yes! But...

In top/plan view (i.e., the view that this plot will be output in) the view of a pipe is a rectangle. And, in fact, even when viewed in 3D, the zoom level has to be pretty high in order to tell that what should be a round pipe is not rendering round. And even more importantly, rendering a round object takes a whole lot more processing power than rendering a square object. So if it won't matter in plan view (and it won't), why use processing cycles unnecessarily?

©2009 Gregg Hillmar | Vectorworks Light Plot Reconstructed
So, I now have 3D extrude sitting directly on top of a 2D rectangle. In top/plan view, there is no visual difference.

I'll select both objects, usually by option-dragging across the two objects. By grouping them (Modify>Group) and then using the Convert to Light Position (Modify>Convert>Convert to Light Position), the 2D and the 3D aspects of the position are created. In the dialogue box, I'll name the position FOH and then select OK.

This creates a new symbol in the file and makes it a Light Position Object (LPO). The symbol, as with all symbols is viewable via the Resource Browser, where it will be "loose" on the top level of the file. I like things rather organized, so I'll make a "positions" folder and move the symbol to that folder. There are several advantages to the LPO being a symbol, foremost perhaps is that it can be reused. If the 2nd FOH position is the same size as the 1st, I can make the FOH symbol my active symbol and place it in the 2nd FOH position using the Light Position Object Tool from the Spotlight toolset, and it will automatically convert the symbol to a LPO.
Another benefit is that symbols can be imported from other files, so a 14' tall boom, once drawn, can be brought into any new file and used immediately.

Worth mentioning again at this point is a third party set of macros called *AutoPlot*. One of the many exceedingly useful macros in *AutoPlot* is a Create Pipe Symbol command that takes a line drawn in the place of a pipe and converts it to a 2D and 3D representation of that pipe. The Convert to Light Position menu command can then be run on the symbol, and in three steps instead of many, the position is created.

One of the nuances added to Spotlight in Vectorworks 2010 is a dialog box that appears if only a 2D object or only a 3D object is selected when using the Convert to Light Position command. The dialog points out that a 2D object may not appear correctly in a 3D view and visa versa to ensure that the desired action is really taken.

**Lighting Positions; OIP**

With the FOH position still selected, looking at the Object Information Palette reveals some interesting changes. First, while the symbol created was just "FOH," I'll change the position name to "1st FOH." The 2nd FOH might use the same symbol, but that position name would be changed to "2nd FOH."

The OIP notes the X and Y position of this object, as expected. It is now showing a "Z" height, which is this position's height in 3D space. Defaulting to "0," this position is sitting on the stage floor. To find out where that position belongs, I'll use a saved view to pop over to the section drawing of the theatre and measure the distance from the 1st FOH to the stage floor level. While there is a perfectly good tape measure tool in the Dimensions Tool Palette, I usually grab the Line Tool from the Basic Palette because it is available without switching palettes. On the section, I'll click on the 1st FOH position and drag down to the stage level. Here is where two of the new features available since Vectorworks 2009 really shine: as I'm moving around the section close to the stage floor, my cursor is picking up multiple snap cues from the hatch and stipple used to represent the cut portion of the stage. With my cursor over what I think is the
of my line as read in the HUD is 24'-0". The Escape key releases the line without placing it, and I can use the previous view Hot Key (command-shift-comma on the Mac) to return to my positions layer. With the 1st FOH position still selected, I can enter 24'-0" into the z height in the OIP.

I now have several options I can select. I can choose to display information on the plot of this position by checking on the Position Summary box. By itself, this just displays the Position Name. I can choose to display an inventory for this position as I add instruments. I can display color cuts as I add that information to the plot. The position will also count circuits based on the instrumentation, and it is smart enough to know that two instruments transferred together using the Twofer Tool from the Spotlight toolset share a circuit. All of this information is useful while developing the plot and can be toggled on and off as needed for the work.

I can also choose to have the position automatically number instruments as they are added to the position. They can be numbered right to left, left to right, top to bottom or bottom to top, depending on the orientation of the position. A standard position in a normal proscenium theatre would be left at the default right-to-left setting while a boom drawn vertically might be numbered top to bottom. A position running upstage from the proscenium would be numbered bottom to top, while a boom on Stage Right, if drawn horizontally, would be numbered left to right. Later in the development of the plot, instrumentation added to the position might be numbered with "points" (i.e., instrument 7.5 is an added instrument between #7 and #8) or alpha designators (7A), in which case the Auto Numbering can be unchecked to turn it off. I can also choose how MultiCircuit units are numbered, so if a 3-cell SkyCyc was unit #4, the cells could be 4A, 4B, and 4C, or cell 4.1, 4.2, and 4.3. Vectorworks Spotlight is not going to force me to use just one system; I get a choice of how I want information to appear on my plot.
Curved Lighting Positions

I work in several theatres with curved lighting positions. One recent theatre I worked in had curved FOH positions and a curved cyc pit for lighting a wrap-around cyc. These installations require a little more work but can be easily accomplished.

The DWG file I received from the Production Manager indicated the FOH positions using arcs. The Master Electrician, however, said that the actual hanging positions were straight runs of pipe, 10'-6" long. Knowing where those facets are can help a great deal in accurate placement of instrumentation.

So, using the imported DWG geometry as a guide, I use the double-line Polygon Tool to draw the 2D representation of the position. After selecting the tool from the Basic Tool Palette, I click on the Preferences button and set the separation at 2" and the option to just draw a polygon. The cursor snap gives me the start point on the arc. I tabbed into the HUD and set the length at 10'-6". Moving the cursor until it touches the curve, I click and place the first segment of the polygon. Tab into the HUD and, entering 10'-6" again; click on the curve where indicated and repeat until the end of the position. Double-click to end and create the polygon. I made sure its class is Draft-Medium. Duplicate in place, extrude, group, and use the Convert to Lighting Position command. I'm done.

If, in fact, the position really had been a curve, I'd first try the Arc Tool from the Basic Toolkit. Usually it is easiest to use the "Arc by three points" mode: the first of the three points is one end, the second is where the arc crosses Center Line, and the third is the other end. If the position is a true arc, this works nicely. If not, I'll turn to the Polygon Tool and place straight line segments over the curve. Once placed, I'll use the 2D Reshape Tool to change many of the straight segments to Bezier curves to match the architectural curve. In either case, I'll make sure the object is in the Draft-Medium class.

I'll then select the polygon or the arc, duplicate it, and use the move command to move the new object 2 inches from the original toward the "center" of the curve. Selecting both the original and the now-moved new object, I'll use the Clip command (Modify>Clip Surface). This causes the top object (the new object) to clip the lower object. Deleting the top object leaves a 2-inch wide polyline representation of the curved pipe. Make sure the ends are closed and that those lines are shown, not hidden. This is the 2D part of the position. Duplicate, extrude to create the 3D representation, group the two, and Convert to Lighting Position. A curved Lighting Position Object is now ready to use.
Lighting Positions: Truss

Often in theatres or in industrial or touring productions, positions are trusses.

Using the Straight Truss Tool from the Spotlight Tool Palette, I'll draw a line where I want the truss. Vectorworks Spotlight automatically creates a hybrid object; it already contains 2D and 3D information. In the OIP, I can edit information as needed, including the truss profile, its size, and so forth. While I can specify its Z height here, it is better to wait until the truss is a LPO to add the height. Vectorworks 2010 also includes truss symbols from major manufacturers that have been modified for more exact use and specification when the generic truss is not accurate enough.

Once I’ve spec’d the truss, I’ll use the Convert to Lighting Position command to make it a Spotlight Smart Object, giving it all of the attributes that have already been mentioned. It is also now a symbol, which means that it can be made active and that new positions can be placed using the Light Position Object Tool. Edits made to the symbol will, of course, be reflected in all instances of that symbol. One thing I always do is edit the 2D truss symbol components to be in the Draft-Medium class so that they draw in the proper line weight on my printed plot.

Truss is often used as a vertical position, as a designated boom, or some other part of the rig. And while I can specify the hanging angle and rotation of the truss in the OIP to set the truss vertical, there are other issues with vertical positions. I’ll devote some time to them later in the book.
Focus Areas

Once the positions are defined, I start laying out lighting areas based on the architecture and the scenery. While it is important to remember that I am lighting action and actors, not space, I have to deal with physics and how light and lighting equipment perform. Designating areas to light is dealing with space. Where those physical chunks of space are and how they relate is part of the design decisions made for every production.

I start by creating a new layer called "Areas." I usually place it right above the scenery layer in the stacking order, and make it the active layer. At this point, I’ll set the position layer to invisible and, possibly, the scenery layer to grayed. Then I create a new saved view.

I use the Rectangle Tool to designate an area. Now, I know that light does not fall into nice neat little squares, and most of the time I don’t want it to. But a square or rectangle is a nice graphic representation of a chunk of space to light. Other folks find circles or ovals more to their liking. That works OK as well. I know also that I am really lighting a 3D chunk of space, so a “cube” of space is being represented, not just a rectangle or circle.

How large this rectangle is will depend somewhat on the size of the theatre. In my practice, areas are never any bigger than 8’ x 8’. I also like to have an area splitting the Center Line of a theatre, especially in a proscenium. That means there will be an odd number of areas across the space. I’ll work the math and find the best combination for the space, the scenery, and the needs of the production.

So, with the Rectangle Tool I draw a square (tab into the HUD, enter 8’ into the (delta)X field, and then constrain the rectangle to 8’ x 8’ by holding down the shift key), click to place, make sure it is in my draft-tech class (thin red line, no fill). I then move it to the furthest Down Stage Right Position. If I’m doing a dance production or something without a lot of scenery, I can use the Duplicate Array command (Edit>Duplicate Array) to populate the rest of the areas. Using the Rectangular Array, 5 columns and 4 rows places 20 duplicates of the selected rectangle. By setting the distance between columns at 8 feet and the distance between rows at 8 feet, the duplicates will be evenly spaced across the stage, 40 feet across and 32 feet deep. Make sure the Original Object is retained, and leave it selected. Clicking OK places the duplicates and leaves them all selected, including the original. Usually I’ll group these all so they can be aligned to the stage as needed.

If there is scenery on the stage, I might use the Duplicate Array command initially, with perhaps fewer rows, and then duplicate and move individual areas as needed over the scenery.
Next I'll grab another of the Vectorworks Spotlight tools that work together to help create the plot. From the Spotlight toolset, I'll select the Focus Point Tool. Moving back into the Down Stage Right area, I'll use the SmartCursor clues to click in the center of that first area designation. Even though the areas are all grouped together, I still get clues from the individual objects.

A click at the place I want the Focus Point Object will first bring up a dialog box. This first area will be Area A, so I'll change the Name to "A." It is now asking for a height. Again, even though the plot at the end of this process will be a 2D output, Vectorworks Spotlight works in 2- and 3-dimensional space, and it is in that 3-dimensional space that many of the Spotlight tools work. So in the 3-dimensional space, 5 feet is a good generic height for where the instrumentation will be focused. If, however, the actors were on a 2' tall platform, that Focus Height should probably be changed to 7'-6".

Clicking OK places the Focus Point Object. It has a generic container around it and uses whatever font was last used. Luckily, I can change the graphic attributes and the object will retain all of its functionality. As with most other aspects of the program, Vectorworks Spotlight does not force me to use only its choices. It allows me to control what my plot will look like. I use a class called focuspoint that has no line and no fill. Unfortunately, classes can not control font or other text attributes, so I'll set the font to my desired typeface, style and size. This is the way I like areas designated on my plot.
The Duplicate Array Tool works perfectly well on Focus Point Objects. The last used settings are retained (5 columns, 4 rows, 8' vertical, 8' horizontal, etc.), so I hit OK. Well, maybe not perfectly well, as all of the areas are now Area A. I'll need to select them one at a time and change the name in the OIP to the proper area designation. Nonetheless, relatively painlessly I have all of my areas now labeled, and I'm ready to start placing instruments.
Instrumentation

In Ye Olde Days, after drafting the space and positions, I'd lay down a fresh sheet of vellum, grab the lighting template, and start placing the graphic representation of a particular instrument type in a particular place on a particular position. The template, like most drafting templates, was designed so that a pencil or pen could be run around the inside of a cutout shape of a light, drawing basically an outline of the lighting instrument on the plot. Additional graphics and text could then be added on, in, and around that outline so that the electricians had the information they needed to hang and circuit the plot.

Vectorworks Spotlight uses hybrid symbols to do the same thing. These hybrid symbols contain a 2D representation of a particular piece of lighting equipment as well as a 3D view. Vectorworks Spotlight ships with thousands of symbols representing equipment from all of the major and some of the less-than-major suppliers of theatrical lighting equipment. Many of these are provided by the manufacturers, so they are as accurate a representation as can be had. These symbols contain not only graphics, but much other information as well. The beam angle and field angle of each lighting instrument is specified, as is the candlepower of each specific lamp type and wattage. Also included is the weight of each instrument and the gel frame size.

To use these symbols in the plot, I'll need to import them. In my current file, I'll open the Resource Browser and find the "Files" dropdown menu. I'll choose to "Browse a document" and navigate to the Libraries folder. Usually that is in the Vectorworks Application folder. I keep mine in the Application Support folder so upgrades don't overwrite it. In the Libraries Folder is an Objects-Entertainment folder. Opening that reveals a multitude of files, with audio, scenic and truss symbols as well as the lighting symbols. Most of the time my Master Electrician has provided an inventory of existing equipment, so I know where to start. Opening the Lighting-ETC-imp.vwx, I see symbols of all of the ETC instrumentation already drawn for me. I choose the ones I want and Control-click and then choose Import, and these symbols are loaded into my file. As I like things neat and orderly, I create a directory to hold these incoming symbols, which I'll call something descriptively like "instruments." All instrument symbols will be moved into that Symbol Folder within my file.

There are also third-party sets of symbols available for Vectorworks Spotlight. Of particular interest is the SoftSymbols™ set of over 3,500 symbols, all of which include the current data on beam angle, field angle, candlepower, and so forth in addition to the graphics. The symbols are designed to look more like what a template would have created; in fact, SoftSymbols is distributed by Field Template, who also produces a line of plastic templates perfect for those times when hand drafting—or updating—a plot is still needed. The symbols work perfectly well with both Vectorworks Spotlight and with AutoPlot, the package of macros mentioned previously. Visit them at http://www.fieldtemplate.com. Illustrations #8 and #79 are from plots drafted using SoftSymbols™.

I can also create my own symbols and link them to the Light Info Record database. Practicals in particular are symbols often created “on-the-fly.”
One last step I do is to alter the 2D symbol definition. Most of the symbols provided by NNA are drawn with what I consider a lightweight line. From the Resource Browser, I'll find the symbol now imported into my file. Control-clicking a symbol accesses the Contextual Menu. The "Edit..." choice brings up a dialog box where I will choose to edit the 2D Component. I'll select all parts and change the class to my "Draft-Medium" in the OIP. If there is more than the outline of the light, I might choose to change some of that additional geometry to other classes, but all parts get my class definitions. Accepting the changes updates the lights to look like what I want them to look like. I'll also know that in the future, I can import these "tweaked" versions into other plots directly. As mentioned earlier, I usually keep a personal "library" file where all of my oft-used symbols are kept updated, and I can add them to any file as needed.

Of course, the point here is that—like virtually everything else in Vectorworks Spotlight—I get to choose what my plot looks like. It is not dictated by the program or decided by some odd programmer somewhere with no connection to theatre. My plot will look the way I want, and yet all of the Smart Objects built into Vectorworks Spotlight will continue to assist me in making the right choices. I can choose this symbol style or that style and still expect the program to work. That I can use all of the tools and still turn out the final product looking like I want it to looks one of the major benefits of Vectorworks Spotlight, in my opinion.

Placing Instrumentation

I find that I like to work in an area-by-area fashion. As a lighting designer, I'll think about how a particular action in a particular scene is lit. I'll think about light sources inherent in the set and then inherent to the action. I'll develop a "key" that describes where the light is coming from into each area throughout the show. So, with a nod to Mr. McCandless, I may have a front warm system coming in at 45° from Stage Left(SL). I'd also have a cool system of fronts at 45° from Stage Right(SR). I might then have a system of sides, warm, from SR and a system of sides, cool, from SL. Maybe there is a down light in lavender and a cool back. I'll draw something that looks like what is in Illustration #51.
So if I place a light where the front SL line crosses the 1st FOH position, that light will be at a 45° angle to Area B, and so forth.

In a Black Box space I design in regularly, the lighting positions are a permanent grid, so I'll also include an "elevation" angle designator as well, which makes the key look like Illustration #52.

The circles correspond to vertical angles as seen in Illustration #53. Instruments placed along the angled lines at the circle are at the defined angles.

In either case, I'll align the key with an area, and add instrumentation based on where the key crosses the available positions. Once those lights are in place, I'll move the key to the next area and repeat the process, or select and duplicate instruments lighting one area and move them to the next. As instruments pile up on positions, choices can be made as to which instruments need to shift in which direction to keep the angles as clean as possible.

There are times when working in systems makes more sense. Sometimes doing all of the front warms, then the front cools is an easier way to think about the design. I'll often do "pods" of lights where the instruments in a particular system are all hung as close together as possible. This changes the angle that the light hits each area but is very useful in many circumstances. I'll use pods to suggest light coming from a window or other source, or to highlight the onstage side of dancers for a better composition. Laying out the pods as a system is the easier way in this case.

Instrument Insertion

Just like In Ye Olde Days, the first thing I'll do is start with a clean drawing surface. I'll create a new Design Layer called "plot," and make it the active layer. My areas layer is visible, the scenery layer is visible or maybe grayed, and the position layer is visible. I'll center the view, then create a saved view. I'll set the key, on the areas layer, over the first area to light.
The next choice is an instinctual one, based on experience and knowledge. If I'm lighting Area C from the 1st FOH at a 45° angle, an ETC 19° might be my first choice. I'll open the Resource Browser, navigate through the symbol directories to find the ETC Source 4 19° symbol that I imported into my file, and double click it to make it the active symbol. I can double-check myself by looking at the bottom of the Resource Browser to see the active symbol. New in Vectorworks 2010, making an instrument symbol active also selects the Instrument Insertion Tool. In previous versions I needed to ensure it was active manually. Zooming in on the 1st FOH near where the 45° line crosses the position, I'll use the reference grid to find the closest 18° grid line. I'll center the Instrument Insertion Tool on the position at that grid line, looking for the Smart Cursor cues that tell me I'm over that position. A click will start the placement. Notice, as in Illustration #54, that it doesn't finish the placement.

Back in Ye Olde Days, I was taught to draft lighting plots with lights drawn at 90° to the position. They could be drawn pointing upstage or downstage or to the side, but they were at one of the cardinal points. Other folk like to draw their lights pointing in the direction of the area where the light will focus. Vectorworks Spotlight is not going to make that choice. I get to decide how I want my plot to look. So I'll set the light vertical and click the second time to actually place the light. If I wanted to point it at the area, before the second click I'd rotate the light towards the area and then click.

With the instrument selected, the Object Information Palette shows some interesting information. First, the object is a Lighting Device. Second, the OIP is full of fields of information that is tracked for each and every Lighting Device. The normal Class and Layer menus are there, as are the X and Y positions. There is also a Z height, and that has information in it. The Lighting Device and the position are talking to one another. The Lighting Device says, "Hey, I'm hanging on the 1st FOH position." As seen in Illustration #55, the position field is also already filled in. Earlier in the process, I set the height of the 1st FOH at 24'-0". The Light says, "If the position is at 24'-0", I must be at 24'-0" also!" Likewise, the Position has added one S4 19°
to its instrument count, has added a circuit needed, and, as I fill in the Color field in the OIP, has counted that color also.

So, for the Purpose field, I’ll fill in "Area C Cool," and maybe the Color is R65. The Position is going to dynamically number the instruments as I add them, so I’ll leave that blank. The Master Electrician will provide the Dimmer, and I usually don’t add the Channel until later in the process. The frame size, field angle, and so forth are all information that came in with the symbol. There is a lot of information that is tracked for each and every light.

The same information can be edited by double-clicking on the instrument. A dialog box pops up where this information is seen (see Illustration #56). In this box is a dropdown menu that makes it very convenient to choose a Focus Point Object to relate this to light. The Purpose that I already filled in is just a text label; the Focus menu makes a connection to a specific Focus Point.

This gives me access to a couple of very useful tools. First, by checking on the box in the OIP, I can see the Beam and Field of this instrument. The Lighting Device, talking to the Focus Point Object and knowing its position in 3D space thanks to the Position Object, does the math and figures the throw distance and displays the Beam and Field at the Focus Point. Clicking on the Draw Beam as 3D Solid shows the beam in the closest RGB equivalent to the gel color that was entered into the Color Field. The Beam and Field lines also display in color regardless of this check box.
Looking at the Beam and Field, I notice that this light from this distance at this angle does not fill the whole area that I'm trying to light. I might want to use a different instrument. I'll return to my Resource Browser and make the ETC Source 4 26" the active symbol. Back in the OIP, a click on the "Replace with Active Symbol" button updates the symbol, updates the Beam and Field graphic, and keeps all of the other information that has already been added into the other fields.

So I'm getting useful information and making choices in the design process while drafting the plot. The Smart Objects built into Vectorworks Spotlight assist in making the best choices. I can continue by choosing to look at the Beam and Field at a definable Falloff Point past the Focus Point. So I can look to see what the light will be hitting on the floor behind the Focus Point. By double-clicking on the instrument and returning to the pop-up dialog (clicking the "Edit" button in the OIP will do the same thing), I can choose the shutters tab and manipulate shutters and then look to see how shutters would look at the Falloff Point and/or at the Focus Point.
Photometer Tool

The other tool I can use to make better choices is the Photometer Tool. From the Spotlight Tool Palette, I’ll choose the tool and place a Photometer in the center of this particular area. The Vectorworks Spotlight tools all talk to each other, and the Photometer figures the throw at that particular angle from that particular position at that particular height and looks up the photometric information of that particular instrument and does the math to display the footcandles at that particular place. It, unfortunately, does not take the gel into account; the footcandles displayed are not filtered. It does, however, take the 3D world into account. The Photometer in Illustration #62 is displayed at Elevation 0°. The Area C Focus Point had been set at a height of 5'-0". By changing the height of the Photometer to 5'-0" in the OIP, the Photometer, now in the center of the beam, recalculates and displays the new footcandle reading.

In the theatre, I don’t much care what the actual number of footcandles is at any given place, but if the production was being filmed or otherwise designed for a camera, such information could be important. What I do use this for in the theatre is to check for dark spots between areas. If the entire system of cool fronts has their beams turned on, by moving the Photometer around, I can check for even coverage. Better yet, I might use the Photometer Grid Tool to place a definable array of Photometers over the stage and check for even coverage. It is a very useful tool in the process of creating the plot.
Moving Lights

Moving lights are treated the same as any other instrumentation in Vectorworks Spotlight. They are a 2D/3D hybrid symbol that can be edited to look like other instrumentation. For me that means lineweight, fill, and so forth. They need to be placed via the Instrument Insertion Tool just like other instruments. Once placed, their device type should be a "Moving Light," but in all other regards they are the same as "Lights" on the 2D plot. Moving lights use multiple channels. I usually designate only the starting channel.

MultiCircuit Instruments

Vectorworks Spotlight does deal with MultiCircuit instruments in an intelligent fashion. These are instruments such as strip lights or cyc lights that need multiple circuits, dimmers, colors, and channels per unit. The strip light and cyc light symbols that ship with Vectorworks are already built as a MultiCircuit instrument and can be placed as a single unit. Each cell, however, can have separate information, and its paperwork is treated as a separate entry. How the cells are numbered is specified in the position options available by selecting the position and accessing the OIP.

MultiCircuit instruments move all as one piece. When selected and dragged, the ghost outline appears as if just the one cell selected is moving, but all redraw in the new position. This makes exact positioning an inexact proposition, so I often nudge the instrument into the right place.

A MultiCircuit instrument can be created for special situations by first creating multiple Lighting Instruments Objects to represent the separate circuits. Select and align them as desired. Then the Modify>Convert> Convert to MultiCircuit command creates a group of instruments that will act as a MultiCircuit unit.
Label Legends

As I add instruments to the plot, I'm filling in some of the data fields as I'm going along. I'm noting the purpose, the color if I know it—or a placeholder if discussions with the scenic designer and costume designer have not resulted in a positive grasp of the rest of the environment. So I might put C1 for the front cools, C2 for the warms, etc., until I can better define what that cool or warm gel might really be. Eventually I'll be adding the control channel, and there might be gobos or other special items used with the light. It might be nice to see that data on the plot as I'm working and then pick which of that data shows on the plot when printed. These details are all handled through Label Legends.

From the Tools Menu, I choose the Label Legend Manager. Since I'm working from an existing file, my Label Legend Manager has some legends in it. In a brand new file, there will be no Label Legends listed. However, Label Legends are saved in the file as resources, which means that once created, they can be imported into any file via the Resource Browser, just as any symbol or texture or hatch can be imported from any other Vectorworks file.

I'll choose to add a new legend. I'll fill in the name as "Vertical" to let me know that it is for instruments vertical onscreen. I have Label Legends for three of the four cardinal positions I use (vertical is the same either up or down if the Flipped Text Preference is turned on) and one for accessories. Others are built as needed, but these work for 90 percent of my plots. Next I see a list of all of the data fields that Vectorworks Spotlight uses to track data for each and every light and accessory in the plot. I can choose which of these fields display on the plot. For instrumentation, I'll want to see the Purpose, the Unit Number, the Coor, the Dimmer, the Channel, User Field 1 (which I use for special notes), and the Gobo 1 field. I can specify that any of these fields are Right Reading (i.e., are always aligned with the bottom or the right side of the screen and, ultimately, of the piece of paper). I choose to have the Unit Number, the Channel and the Dimmer set to right reading so that they are always "straight." Things like the color, however, which have a placement more related to the instrument I'll leave not right reading. This way, as the instrument rotates, the color rotates with it and stays in alignment with the instrument. The choices checked rotate also but stay aligned as in Illustration.
#66. If I want all of the information stacked and to never rotate regardless of the rotation of the instrument, there is a Non-Rotating checkbox that can set that option.

I can also choose if there will be a container around the information. I've always used a circle around the dimmer and a hexagon around the channel. Everything else has no container. Vectorworks Spotlight uses several defaults, but individual choices can be added to the container directory in the Resource Browser and used as desired. For my horizontal legend, the default hexagon aligns on the flat side, not on one of the points as in the vertical orientation. So I've created a second hexagon that is rotated so a point is oriented horizontally, and use that in my horizontal legend.

The symbol to use in setting up the layout is indicated and can be changed. It will default to the last-used symbol.

Clicking OK returns the screen to the Label Legend Manager. Clicking on "Edit Layout..." will then display the Layout box, where the fields are indicated in the blue box on the left. They can be selected and dragged into place around the instrument. The font, size, and style of the

---

Illustration 67

---

88 Vectorworks Light Plot Deconstructed | © 2009 Gregg Hillmar
text can be changed, as can the color. They can be rotated as desired and placed carefully, including by using the OIP, if needed. My Unit Number, for example, is set to align centered both vertically and horizontally. I'll then use the OIP to put the insertion point at "0,0" so it is always in the center of the instrument. The Color field is set to align center horizontally and to align to the bottom of the text vertically. I'll then set it at "0" on the X axis and aligned with the front of the instrument. Likewise, the Dimmer and Channel are aligned centered vertically and horizontally and set at "0" on the X axis. Note that even though I set a container around these fields, that container does not show up in the Label Legend Manager. This means that I have to roughly these into place, accept the layout, go back to my drawing, apply the Label Legend to an instrument, look at the alignment, go back to the Label Legend Manager, back into Layout, adjust the placement, accept the layout, go back to my drawing, refresh the drawing to see the new placement, look at the alignment, go back to the Label Legend Manager, back into Layout, adjust the placement, ad infinitum, until all parts are aligned as I'd like them. As I said, thank goodness that Label Legends are importable, so this only needs to be done once. After that, these legends can be used in any other file.

While my "vertical" legend is rather simple, I have three legends for instruments along the horizontal axis. As mentioned, my generic horizontal legend is the same as the vertical one except I use a hexagon with a point in line horizontally. When stacking instruments on an electric or other position where the channel and dimmer would interfere with a light further right or left, I use a SR side or SL side legend that has the Dimmer and Channel below the instrument. This allows the instruments to be designated on the pipe as close as in real life, while the information is displayed without impacting other instruments. I set those Dimmer and Channel designations to be along the "0" line (the "x" axis) so that when twofers are noted, the twofers, which always attaches to the light at the insertion point ("0,0" in the Label Legend Manager Layout), seems to spring from the Dimmer/Channel graphic.

Applying these labels to instruments is relatively easy. With an existing instrument, the easiest thing to do is double-click on it, and in the dialog box choose the desired legend from a dropdown menu. Or, with the instrument selected, type the name of the legend into the Label Legend field in the OIP. To use the same Label Legend for all new instruments, make sure no instruments are selected, open the Label Legend Manager, and check on the legend desired. All instruments created thereafter will use that legend until it is changed.
In those odd occasions when the legends overlap other information, the individual labels can be moved on an instrument-by-instrument basis. With the instrument selected, each label has a handle available that allows that label—and that label only—to be moved as needed. Illustration #64 shows channel labels that have been moved to the side. If I need to restore the default label position, I can choose the Modify>Assign Legend to Insts menu command with the instrument selected, and it will restore the default.

Finally, each label is put into its own class. The Dimmer label goes into the Label-Dimmer class, the Purpose is in the Label-Purpose class, and so forth. This will be very important when I lay out the plot to print because information I want on the plot while I am working on it is not necessarily the information I want on the plot when it is printed. Classes will allow me to control those aspects. I'll talk more about that later in the book.
Accessories

Accessories come in two flavors. There are those accessories that need a control channel or two such as color scrollers, and those, such as a top hat or barn door that do not need control. In Vectorworks Spotlight, accessories that do not need a control channel are "Static" Accessories, while those that do are just Accessories. While both are placed the same way, they are dealt with differently in paperwork and how I choose to display them on the plot in terms of Label Legends.

Vectorworks Spotlight ships with hundreds of accessories already drawn and saved as symbols. Like the instrument symbols, many are provided by the manufacturer, and there are also USITT standard symbols as well as "standard practice" symbols available. Likewise, many of the third-party symbol sets include accessories. To access the ones that ship with Vectorworks Spotlight, in the Resource Browser I'll use the Files dropdown menu to "Browse a Document." Navigating to the Libraries folder an Objects-Entertainment folder. That folder contains a multitude of files.

One of those is generic accessory symbols while other accessories are in their manufacturer-specific file. So, I might want a generic barn door, for example. I'd open the Lighting-Accessories Imp.vwx file and find the 10" barn door. I could then import that, as already discussed, into my file and place it into my instruments symbol folder. If I also need a ChromaQ color scroller, I'd navigate to Lighting-Chroma Imp.vwx and open that file. Again, I'd import the symbol I needed, continuing until all of the accessories I want are in my file. As I did with the instruments, I'll then alter the 2D definition of these symbols to match my class definitions.

Placing the accessories works the same regardless of the type of accessory. I'll double-click on the desired accessory in the Resource Browser to make it active; in this case, it is a 10" barn door. Selecting an accessory now makes the Accessory Insertion Tool active; in previous versions I'd choose it manually. The first click with the tool inserts the symbol, but the process is not complete. I clicked on the front center of a 8" Fresnel, using cursor cues to get the insertion point in the right place. I can now rotate the symbol as needed to match the rotation of the instrument. If I had pointed the instrument at an angle to point to the Focus Area, I could match that; in my practice this instrument is 90° to the position so I'll rotate to horizontal, and the second click will place the accessory. The cursor then turns to a "bull's eye." A third click on the instrument itself relates the accessory to that instrument.

The first thing I notice is that the accessory I just placed is now covering a gel specified in the instrument. This is just a stacking issue, so with the accessory selected, I'll choose the Modify>Send>Send to Back menu command. I've learned the key command shortcut, so it is a simple one-key press operation that is part of my routine now. The accessory is now "behind" the instrument, and the color shows as it should.
The next thing to notice is that the OIP is giving me new information about this object. It is now recognized as a Lighting Device, and its Device Type is a Static Accessory. Instrument Type is listed as a 10" Barn Door. The Barn Door also knows that it is "on" Unit Number 4 on the 1st Electric. And it also knows that its Z height is 22'-0". Again, these Spotlight objects are sharing information; if the 1st Electric Position is specified with a height of 22'-0", the instrument knows that it is at 22', and if the instrument is at 22', the accessory related to it also must be at 22'. In fact, if I move the instrument to a different place on the electric, the accessory will move with the instrument.

Aside note: if I moved that instrument so it was "on" the 2nd Electric, the instrument would recognize that and the Position would automatically update, as would the Z height. The accessory would also update, as would the 2nd Electric Position Object, where one more instrument and one more circuit would be added to the count, as would the color in that instrument.

As a related side note, if a Position Object is moved—either its actual location on the plot or its Z height in 3D space—all of its instrumentation and their accessories move with it. Once moved, all of the information for each instrument and accessory such as the X, Y, and Z locations will automatically update as well.

A barn door is a static accessory, so it has no control channel or circuit. If I use the same procedure as above to place my color scroller and assign it a Label Legend, I can display that information as desired on the plot, and that information is shared with paperwork.
Aligning Instruments

Once the plot is more or less laid out properly, it is time to start cleaning it up in preparation to print. The first thing I do is align all of the instruments to their assigned positions. Even if the grid snap is on while placing instruments, I find they are often not as exact as I would like them. In a proscenium theatre, or any theatre with a centered plot, I often export the "X" location into my paperwork so an electrician has a clue as to how far from center to look for that instrument. In Illustration #73, the X field would export as 1'-7.313", where it should be 1'-6".

If using other objects, I use the Modify>Align>Align to Grid menu command to move it to the closest grid points. Unfortunately this command works with the outside edges of the object, which won't help this object at all since it is the center of the instrument that I want aligned, and that is what the X and Y fields are reporting. One option is to enter the desired measurements directly into the OIP. However, doing that for every instrument in a plot of any size would be painful.

Vectorworks Spotlight does contain an Align and Distribute tool that makes this somewhat easier. I would use the Modify>Find and Modify menu command and select all of the 1st FOH instruments, for example. Using the Align and Distribute Tool from the Spotlight toolset, I'll draw a line along the 1st FOH position, and up pops the dialog box noted in Illustration #74. This allows me to Distribute—Along the line on 1'-6" centers—all of the selected instruments from the starting point of the line. So the instruments in the illustration with a 6'-0" gap between them would redraw with no gap and would be scrunched together at the far end of the line. If I choose the "Just:Align" option, the lights will align along the drawn line—in this case along the Y axis—but will not change their X position at all.

AutoPlot, a set of macros available as shareware from Samuel L. Jones via http://www.autoplotww.com/, has a series of macros that makes Alignment options much easier. Once loaded into a workspace, the macros are available as menu commands, or in the Contextual Menus. In this case, I would select one instrument on the 1st FOH, and then I'd use the "Align TB on Position" command to exactly align the Y value of each light with that same position to the Y coordinate of the position. With the lights still all selected, I would also
run the "Move to Closest Unit (H)" command, specifying '18" as my unit, which would move all of the lights so that their X value (horizontal) is at that closest point. This all assumes, of course, that the X and Y coordinates are set up as initially described, usually with the '0,0' point at the Center Line and the Plaster Line in a proscenium theatre. The "Move to Closest Unit (H)" command does prompt for the starting point of that measurement; I usually use CL, but the end of the pipe or any other point can be used. Two commands and all the instruments on this particular position are aligned. While Vectorworks Spotlight does provide much of the same functionality, AutoPlot does it easier and faster.
Twoferring

After aligning or otherwise moving all of the instruments into the right place, I might consider adding twofer information to the plot. In general, I do not notate twofers on the plot, leaving it up to the Master Electrician’s discretion as to when and what to twofer. They have a much better idea of their circuiting possibilities than I ever will. Still, sometimes it is useful to designate some twoferring on the plot.

Once channels are assigned, the twofer possibilities are easy to look for—any two instruments with the same channel can potentially be twofered. If the Light Position has the Sum Circuits option checked on, the number of circuits—one per instrument—is displayed. When that number is above the number of circuits available, some twoferring or additional cabling will be necessary.

Choosing the Ganging Tool from the Spotlight toolset, I’ll click once on the first light to be twofered. Click a second time on the next light and then a third time where I want to actually notate the twofer. If the assigned channels do not match each other, a dialog box appears asking me if I’m sure I want to twofer those two lights. Choosing Yes causes the first light clicked to be the channel of both lights, and the twofer is placed. If the two lights have the same channel, the twofer object is placed where indicated.

I can click on and drag the channel indicator to change the placement of that graphic. This usually causes a moment of panic because the entire twofer appears to be moving, as shown in Illustration #77. However, when released, the twofer redraws correctly in its new place.

Illustration 77

Twoferring two lights does cause the Position Object to deduct one circuit from the number of circuits it is counting. Unfortunately, deleting the twofer does not cause the count to automatically update. Indeed, even the Label Legend does not automatically update, although the missing channel graphic will regenerate when the instruments are redrawn using the Modify>Refresh Instrument command or through other means.
Vertical Positions and Instruments

One of the ongoing issues with Vectorworks Spotlight has been the handling of Light Position Objects in 3-dimensional space. While a standard position works quite well as a 2D and 3D hybrid, booms, vertical trusses, moving pieces, and the like fail to work as well as one might desire.

The problem is based around two competing ideas. First, the plot must be crystal clear as to the hanging positions and the arrangement of the lights on that position. The plot is a 2D representation of that information.

Second is the desire to have all of the smart functionality built into Vectorworks Spotlight work as it should on vertically hung lights, which is based on the 3D placement of those lights. And perhaps third, although out of the scope of this book, is the desire to use the actual plot to render cues or looks in that 3D space.

My point of view, as expressed elsewhere, is that the final output desired is the 2D plot. What that means in my practice is that booms, by far my most common example of vertical positions, are, as they were in hand-drafted plots, drawn as if laid out on the floor. I choose to show elevation, circuiting, control, color, and so forth for all of the instruments on the plot. My section might also show elevation, but not circuiting, control, color, etc. That information is most needed on the plot. I'll show that information in a couple of different ways—sometimes with the booms drawn horizontal, sometimes vertical, sometimes at an angle, all depending on the rest of the space and drawing. In large dance shows, I've even moved the booms onto separate sheets referenced to the plot. But clear communication is the point, not accurate 3D modeling.

The problem, of course, is that in this arrangement it is no longer possible to check the beam angle or area coverage or any of the other functions available through Vectorworks Spotlight. Basically, the lights are not in the right place in 3D space to use these tools.

What I do is place a "test" light at the correct place, make sure its Z height is right, and check all of the positions' focus with the beam and fields turned on. I'll change the Z height and Focus Point as I work through the position, making sure my choices will work. I then draw the graphic representation as needed. Again, for me, the plot is about communication.
correct 3D position is turned off via classes or through the Lighting Symbol not having a 2D definition. In these cases, the designers build specific Label Legends, or use the ability to move specific parts of the Label Legend individually to properly notate the instrumentation on the plot.

To solve this issue, a new command was added to Vectorworks 2009. In the built-in solution, I'd first suggest that the symbol being used as the Light Position object have a 3D component already. Most of my symbols do, as that is the only way that a Z height can be added, but some of my boom graphics were 2D only. Adding the 3D component first made for a better looking 3D model.

Second, the position and the instrumentation must be on the same layer. I usually keep the positions and the instrumentation on separate layers, if only to be able to easily delete the instrumentation for a particular production and use the remaining drawing for the next production I'm designing in the same space. But this command works best if all of the Spotlight geometry is on the same layer.

The Vertical Position is first drawn on the 2D plot. In Illustration #80, the Lighting Position Object is a Boom.
Lighting Objects are placed on it just as they were in the past. Then, with the Lights and the Position Objects selected, the View>Create Plot and Model View menu command is run. This command will move the selected Lights and Position Objects to a new Design Layer and then reference those back to the original layer as a Design Layer Viewport (DLVP). It will also create a 3D DLVP onto an existing model layer, or create new model layer. The first dialog presented when running the command names the new "Definition Layer" where the position and the instruments will reside. In the illustrated example, I've chosen to leave the defaults.

In real life, I might call this Boom 1 SL or some more descriptive layer name. I'm also going to default to a new Model Layer for the 3D geometry and ask that the command automatically rotate the position and lights to a Vertical position.

The new layers and DLVPs are created as seen in Illustration #81. On the plot, the boom is now a DLVP, so access to the original is through the Viewport or via any standard layer navigation method. The Definition Layer should be turned invisible in most instances. The DLVP could then be placed as desired on the Plot Layer and annotated or manipulated as per a DLVP. In the 3D Model Layer, the booms can be rotated and placed accurately so that they can be used in section and elevation drawings.

The Create Plot and Model View command does not deal with Focus Point Objects, so the accuracy of Beams and Fields or Shutters still needs manual intervention. However, the ability to accurately place instrumentation in 3D space and not have to redraw booms and other vertical positions for sections, elevations, or renderings is a great step forward.

Also worth noting is that if there are no positions selected when this command is run, all positions will be moved to new Definition Layers, one per position. And, while it may be obvious, note that the 3D model uses the Lighting Instrument's 3D geometry, which in the symbols that ship with Vectorworks.
Spotlight show the instrument in a typical hanging position with the instrument at about 30° to the yoke. For 3D accuracy, I'll create a separate symbol for booms with the 3D version of the light hanging from a sidearm. This then renders accurately in sections and so forth.

Also note that in the Model Layer, the position and its accompanying lights can be rotated as needed without changing the 2D layout of the position on the plot. Actually, what is being rotated is the Viewport of the layout, not the layout itself.

All in all, this command does address many of the problems with vertical—or other non-horizontal—lighting positions.
Paperwork

A rudimentary paperwork capability is built into Vectorworks Spotlight. By using the Tools->Reports->Generate Paperwork command, a dialog box allows the setup of a worksheet that presents an Instrument Schedule and all of the other typical reports needed for the electrician as paperwork. These reports can then be accessed via the Resource Browser and placed on a layer much like a symbol. It is all one long graphic, so printing it might be a bit convoluted. A double-click on the graphic does open an editable worksheet where changes made are seen both in the paperwork and on the plot. This 2-way worksheet can be used to enter data for each light in a spreadsheet-style environment.

While this functionality may be useful to some users, for many years now I have used Lightwright to do my paperwork. Written by John McKernon, Lightwright is an industry standard. Information about each and every light in a plot can be tracked, changed, displayed in a variety of ways, and dealt with in the computer, not just on paper. Focus charts and work notes are incorporated into the program, and any kind of graphic such as floorplans or sketches to illustrate the focus or a note, can be imported and used. For more than 20 years, Lightwright has been used by designers and electricians alike for its ease of use, speed, and versatility. Paper versions of the file can be printed in a variety of forms when needed. Visit www.mckernon.com for more information about Lightwright.
In previous versions of Vectorworks Spotlight, once the plot was mostly done, I would use the File>Export>Export Instrument Data menu command, and with one click of the Lightweight button in the ensuing dialog box, all of the fields with information that Lightweight needs would be selected. That information was then exported as a text file, which could be imported into Lightweight for further manipulation and use. I, for instance, found it easier to assign channels in Lightweight where I can sort the instruments by purpose or by color to make data entry easier. In Lightweight, the updated information could then be exported again to a text file that Vectorworks Spotlight could read, and the plot was updated as required.

This was all well and good, but it did require some care in importing and exporting and knowing when to do which step and how to manipulate the data. And did I really change something in the paperwork that I should export and import before I make a change on the plot and then export that and import and...?

Luckily, since Vectorworks Spotlight 2009 and with the release of Lightweight 5, the import/export juggie is a thing of the past. Using the File>Document Settings>Spotlight Preferences... menu command, there is a tab that turns on a new feature: an automatic data exchange with Lightweight. In simple terms, the Export fields chosen in that dialog box are written to a file that is constantly updated by Vectorworks Spotlight.
Opening *Lightwright 5*, I can choose to use the automatic Data Exchange and can point *Lightwright* to the file that Vectorworks Spotlight created. Vectorworks and *Lightwright* will now seamlessly share information back and forth with no other interaction needed by me! If I add an instrument on the plot, the new instrument and its information is sent to the paperwork. If I change a channel or a color while working in *Lightwright*, when I come back to Vectorworks, those changes are already in the plot. As usual, though, using the Modify>Refresh Instruments command is necessary to see the changes on the plot. I can add accessories or even add lights in *Lightwright*, and they will be drawn in Vectorworks Spotlight. Looking in my Resource Browser, an “Import” worksheet is automatically created that lists instruments that have been added. Using a Control-click or right-click on the worksheet row gives me a “Select Item” choice that will select the added item so I can properly place it on the plot.

Through some other parameters, I can arrange *Lightwright* to receive updates from my Master Electrician as well, so as circuits and/or dimmers are assigned and added to the M.E.’s paperwork they will be automatically added to my file—and are automatically added to my plot as desired. Obviously this feature can be toggled on and off, so updates are automatic only as long as I want them to be. Certainly while drafting the initial plot and working back and forth from paperwork to plot, this data exchange is absolutely wonderful!

*Lightwright 5* contains a number of other improvements, all of which make it a really nice upgrade. The combination of Vectorworks Spotlight and *Lightwright 5* is unbeatable in my book. If, however, I was using an earlier version of *Lightwright* or was still using my “roll-your-own” Filemaker database for paperwork, I could still use the export and import commands as mentioned earlier.
Viewports

In Ye Olde Days, after roughing in the plot and making sure I like where everything is, I would lay a clean sheet of vellum down on top of the stack on my drawing board and trace up all of the things I wanted to keep and display on the plot. In Vectorworks Spotlight, I still do something similar. I've been drawing the plot on Design Layers. As I finish the plot, I'll use Viewports extensively to create the views I want to print. They will be arranged on Sheet Layers. So I'm still "tracing up" what I want to show on a "clean" sheet.

When a Viewport is created, it will default to the class and layer setup current at its creation. So I'll set the Design Layers as I want the plot to appear. I may have the theatre 2D layer visible, the scenery floorplan on but grayed, the positions layer and the plot layers on, and so forth. With nothing selected, the Views>Create Viewport command will bring up a dialog box that allows me to specify what information will be displayed. I'll often adopt the default name and give it a descriptive title in Vectorworks 2010. I can click on the "Layers" and/or "Classes" buttons and define which layers and classes are visible, grayed, or invisible, but I'll assume that the default I set up earlier is what I want to see. Likewise with scale, I'll assume that the % scale I originally set when creating layers will work; the Viewport is again using the existing default.

I will create a new sheet layer to put this Viewport on by selecting New Sheet Layer... from the Create on Layer dropdown menu. This will be sheet 1, and I'll title it "Plot to Print" or some other easily identifiable title. Making sure the "Edit Properties after Creation" box is checked on, I'll click OK. In the "Edit Sheet Layers" dialog box that then appears, I'll change the DPI setting to match my plotter DPI, or desired export DPI. I usually use 300 DPI. I'll then click on the page setup and set the print functions to how I want to print. I'll decide whether I want to print a 24"x36" page, or an 18"x24" page and set to print accordingly.
When creating light plots I am usually looking at the plot in the 2D plan mode, not in any of the isometric views. Whatever view is active is used as the default projection when creating a Viewport. Likewise, most of the time I use the wireframe rendering mode, which will be accepted as the default for the Viewport. Both of these can be changed here when initially creating the Viewport or by selecting the Viewport and changing them via the Object Information Palette, but I rarely do so when actually creating a plot.

Clicking OK all of the way out of those dialog boxes creates a Viewport on the new Sheet Layer. Unlike the way I set up Design Layers, Sheet Layers displays the boundaries of the printed page. Looking at Illustration #87: the very first thing I notice is that my plot in ¼" scale does not fit on a 24"x36" sheet.

Luckily, this is easy to fix. I can select the Viewport and change the scale in the OIP. Changing the scale to ¼"= 1'-0" makes the whole plot the right size to fit on the sheet. Unfortunately, text is also scaled, so what was 12 pt. text on the Design Layer is now 6 pt. text. If I think that is too small, I can adjust the text scaling by selecting the Viewport and clicking on the "Advanced Properties" button in the OIP. Increasing the text scale to 2" would set the text to twice the scaled size. I can see what that would look like by clicking on the Preview button and can adjust the text scale up or down as needed to make it look like what I want.

I can also choose to edit the way this Viewport presents data. For example, while working on the plot, I like to see the purpose of each instrument listed beside it. That makes it easy to make decisions on which instruments to move or change while working. However, when setting up the plot to print for the Master Electrician, that information is not at all important.
In fact, it clutters up the drawing. Luckily, Vectorworks Spotlight puts each element of the Label Legend into their own class. With the Viewport selected, I can click on the Classes button in the OIP, which lets me then specify which classes are visible, grayed, or invisible in this particular Viewport. For this plot to print, I’ll make the Label-Purpose class invisible.

Sometimes I will need to show an enlarged detail of a particular hanging solution. I can go back to my Design Layers, usually via a saved view. I will draw a circle around the part I want to detail. I’ll set the circle to have no fill so I can place it carefully. Then, with the circle still selected, I’ll again use the Create Viewport command and send the resulting Viewport to the same Sheet Layer. In this case, the circle now acts as a crop: everything inside the circle is displayed, and nothing outside the circle is seen. I can control the scale of this Viewport without changing any of the others, which means I can present a detail drawing at a different scale without having to redraw anything! A Sheet Layer can contain any number of Viewports, and they can be moved and sized individually so that the layout of the plot to be printed can be easily manipulated.

A couple of other things need to be added to the Sheet Layer to finish the plot, which may have some influence on the layout of the Sheet Layer. The first of those is a title block and, if desired, a border around the drawing. As a compositional element, I’ve always thought that a border helps tie a drawing together and define it. Vectorworks does provide a drawing border tool that can be custom-sized and can contain title block information. New in Vectorworks 2010 is a preference for Automatic Drawing Coordination. If on, the Titleblock will pull information from the Sheet Layers and from Viewports to fill in some of the information automatically. Rather than using the built-in Titleblock Tool, I created my own 2D symbol that contains a border and titleblock drawn the way I want it to look and containing the information I want it to contain. The text information in the title block is related to a database within Vectorworks, so after placing the symbol on the Sheet Layer, that text can be customized via the OIP. As the vast majority of the drawings I do are either 18”x24” or 24”x36”, I have two symbols, one customized for each size, as Sheet Layers are always at a 1:1 scale. Therefore, the title block symbols are not scaled. Placing it is as easy as selecting the correct-sized symbol from the Resource Browser and placing it on the Sheet Layer.
I'm of two minds about how and where to place dimensions and notes. Most of the time when drafting lighting, I will place them right on the Design Layer with the plot. This is one place where setting the scale of each layer at the scale I expect to print in really comes in handy. I know that notes or dimensions I place in 12 pt. text will be that size when printed. I can see the relative size and placement clearly while working directly on the plot Design Layer. My other choice is to use a Viewport annotation on the Sheet Layer, which I use extensively when designing scenery but not as often with lighting plots.

I will rarely dimension hanging positions unless lights are not on an 18” placement. I have a “scale” symbol I place on the Design Layer of every plot that notates that 18” spacing, and I'll include a note that says all instruments are on 18” centers unless otherwise noted. So dimensions are often only used for booms or odd placements.

Notes, on the other hand, can be rather extensive. I tend to use simple text blocks with the Leader Line Tool to relate the note to the object. The Callout Tool also works and keeps the text related to the leader line. I just wish editing the text was a little easier.

Callouts do have an advantage in that it is easy to add a border or other “attention” effect to the note, so I'll sometimes use one of those, although my notes are mostly just plain text.

Through most of the design process, I will have Spotlight's position summary turned on so I can see the number of instruments and other information on the plot. However, I do not care for the look of the summary as provided by Spotlight, so as I move into finishing the plot I'll use a text block to keep my choice of look, text, and arrangement. I can include trim heights or other information not provided by Spotlight's summary. I'll then turn off the summary by selecting the position object and toggling off the summary in the OIP.

A key to the instrumentation is also a valuable item to add to the plot. Defining what each symbol is on the plot will help prevent hanging the wrong instrument in the theatre. Vectorworks Spotlight does automate creating a key. Back on the Plot Design Layer, I'll choose the Tools>Reports>Key to Instrumentation menu command. After selecting...
from the options presented, a click in the drawing will place a key that lists all of the lighting symbols being used in the drawing. This key is just a group, which means it is easily edited. Again, I get to choose what the key will look like; Vectorworks is not forcing me to any one look. Vectorworks Spotlight places the instrument symbols vertical; I like them horizontal. I can easily enter the group and change them. I was also offered a choice to include the active Label Legend in the key. I don’t include that because I have created my own legend and have it saved as a symbol. I can easily place that in the group as I adjust the key to my specifications.

This key does need to be placed on the Design Layer, not on the Sheet Layer so that the scale is the same as the plot. The Sheet Layer is always in a 1:1 scale. If placement options are important, the key could be created off to the side of the plot and then placed on the Sheet Layer via a Viewport, which would provide complete layout freedom.

Additional notes can be added to the plot as needed at this point—if I haven’t placed them on the Design Layers as mentioned previously. Depending on the purpose of the note, I’ll place them in an annotation so they keep their relationship to the objects they relate to regardless of how that Viewport may be moved or resized. If the notes are “loose” on the Sheet Layer, they would need to be moved separately if the Viewport is moved. Some notes, however, are better left “loose.” If I’m placing a standard disclaimer or other standard information on the plot, I would most likely place that on Sheet Layer so I could move it around. Such notes are usually not related to specific items.

Once the plot is laid out the way I want it with all of the elements in their proper place, I’ll do the same process to produce a section drawing on a second Sheet Layer. Additional elevations or details can be created on subsequent sheets as needed. For example, one thing I might do is crop around a particular position and create a Viewport of just that position on a sheet. This can then be printed and used to create “cardboards” so an electrician can take just the 1st FOH hanging information to the 1st FOH rather than the whole plot.

Using Viewports to lay out different views and present different information for different uses, all without redrawing anything, is one of the great advantages of Viewports and Sheet Layers.
Printing

Printing is largely a function of the OS, Printer Driver, and printer, so is a rather individual situation. Since the advent of Sheet Layers and Viewports, I print exclusively from the Sheet Layers I've set up as described earlier. In fact, page setup is a function of setting up a Sheet Layer, so the only thing I really have to do to print is choose to print when the correct Sheet Layer is the active layer. In the print dialog box, among several important options to choose are the DPI and the percentage to print grayed layers and classes. What gets put in those choices will depend on the printer being used, but there are a few guidelines.

As part of the setup of the Sheet Layer, I set the Sheet Layer's DPI to 300. The DPI to print wants to match that number. Printing to my plotter (a HP 500) I've not seen any difference in setting the print DPI any higher.

The percentage to print grayed objects does, as indicated, affect both grayed layers and grayed classes. What to put here may change, depending on the usage as well as the individual printer. I start at 35 percent and adjust after doing a test print to get the visual look I want.

Vectorworks Spotlight does include a Batch Print command where a set of Sheet Layers can be both sent to the printer and saved so printing them in the future is easier. This command works best if all of the sheets are the same size and resolution.

Most of the plots I do these days go out the door not as paper, but as a PDF file. While the Macintosh has had a print to PDF function as part of the OS for a while, Vectorworks now offers an export to PDF function to all users of Vectorworks. In fact, Vectorworks files can be exported to many other formats including DXF, DWG, EPSF, a variety of image file formats, and others.

Choosing the File>Export>Export to PDF... menu command allows some customization to the resulting file, but the final output is a PDF version of the active Sheet Layer that can be emailed off to the Production Manager and/or the Master Electrician. When combined with a Lightweight file and/or PDF output from Lightweight, the plot is finished and out the door without the need of paper and a visit from FedEx.
So there we have it—an intentionally short and easy-to-follow journey from a new, unformatted file to a plot out the door. Vectorworks Spotlight provides a wide variety of tools, commands, and objects that make designing and drafting the plot a much simpler and easier operation than it was in the past. These are supplemented by third-party software, symbols, and macros to really make the final output—the plot printed “on paper”—a plot that we can be proud of. It looks like what we want a plot to look like, not what someone else has decided a plot should look like.

Vectorworks Spotlight is a tool that allows us to visualize, to plan, to experiment and to make good decisions based on the information that it provides. It may be just a tool, but it is a damned fine tool; one of the best in our arsenal as we develop the plot. We are better prepared and have made better decisions as a result of using it. That translates into more time and energy put into the work done in the theatre. And that is what really matters; lighting the action onstage.

All of the illustrations seen here were produced on my Macintosh and use my normal fonts. For the record, my primary font for drafting is a commercial font called Two-by-Four, created by Fonthead Design; available for both Mac and Windows in True Type and Postscript. A search of online type vendors should turn it up. I also use a freeware font called Architect, sometimes seen online as ER Architect. I’ve also got a second font called Architect2 that I don’t have any information on. Searching for Architect fonts online leads to way many fonts...

The illustrations were taken from three files, all based on drawings actually used in production. They were upgraded to Vectorworks 2009 and again to 2010, but few other changes were made to these files. My thanks to the other artists who contributed to those productions and whose work is seen here, notably scenic designers Thor Bumblauskas and David Shuhy. I think Thom can be credited with asking for the first time “when’s the book coming out?” - long before it was even an idea. Thanks Thom... I think...

PDF versions of the three files referenced in this book are available for download at http://www.lightplotdeconstructed.com. Vectorworks 2009 and 2010 versions of one of the files is also available for download to explore class and layer structure, saved views, and other issues outlined in this book. Look for updated information and files at that website as available.

No designer works in a vacuum, so my thanks go to all the directors, designers, assistants, technical directors, master electricians, crew members and students who have shared in this adventure we call theatre. It has been my privilege to work with really great collaborators and support.

Thanks also to my wife Caroline and my daughters Rachael and Margaret, who share some of the less pleasant aspects (time away from home, long hours, late nights, etc.) as well as the joy of theatre well done. I love you all!